Debian Unstable And Ubuntu 15.10 Will Be Using GCC 5 As The Default Compiler

The Debian developers have decided to make GCC 5 the default compiler in Debian Unstable, but Debian 9.0 Stretch will be most likely using GCC 6 as default. Also, Ubuntu 15.10 Wily Werewolf will adopt GCC 5 in a short time.

Since Ubuntu is a Debian fork, the major Debian changes get implemented in Ubuntu also, a good example being systemd.

Also, Debian has finally decided to replace Libav with FFmpeg, because Libav is patched too slowly compared to FFmpeg, so the second may be safer.

Both Libav and FFmpeg are two multimedia frameworks for manipulating media files and do pretty much the same thing. In 2011, the ffmpeg maintainer decided to fork ffmpeg and created libav, which has replaced ffmpeg on both Debian and Ubuntu.

Also, Ubuntu 15.04 Vivid Vervet has included FFmpeg in the default repositories, replacing Libav.

 

Tagged with: , , , ,
Posted in The Linux and Unix Articles!

Leave a Reply

Your email address will not be published. Required fields are marked *

*

Subscribe

  

Subscribe to get the latest Linux news and how to guides directly on your e-mail!