How To Install Gaupol (Subtitle Editor) 0.26 On Ubuntu 14.10, Ubuntu 14.04 And Derivative Systems

Hello Linux Geeksters. As you may know, Gaupol is a simple and open-source subtitle editing tool, having all the needed features: shortcuts, third party extensions, spell checking and speech recognition.

The latest version available is Gaupol 0.26, which has been released a while ago, coming with a lot of changes:

  • Update file selection dialogs to work better with GTK+ 3.12
  • Default toolbar style to icons only (due to gtk-toolbar-style being deprecated since GTK+ 3.10)
  • Allow using the dark GTK+ theme variant (you need to edit
  • ~/.config/gaupol/gaupol.conf to enable this)
  • Fix errors and lack of updates in multiline text cells and their line length calculation and display
  • Fix initially incorrect row heights after opening a file
  • Fix updating subtitle numbers when inserting or removing subtitles
  • Fix overlapping column header right-click menus
  • Fix saving enumeration values to configuration file
  • Use Gtk.render_layout instead of deprecated Gtk.paint_layout to render line length margin in text views
  • Remove header editing dialog
  • Remove non-functional speech recognition menu item
  • Drop support for the MPsub format
  • Add GTK+ (3.2 or greater) to list of dependencies in the README file (GTK+ has always been a dependency, its explicit mention was just forgotten when migrating from PyGTK to PyGObject)
  • Update Brazilian Portuguese translation
  • Update Czech translation

how to install Gaupol 0.26 on Ubuntu 14.10 Utopic Unicorn, Ubuntu 14.04 Trusty Tahr, Linux Mint 17 Qiana, Elementary OS 0.3 Freya, Peppermint Five, Deepin 2014, LXLE 14.04, Linux Lite 2.0

In this article I will show you how to install Gaupol 0.26 on Ubuntu 14.10 Utopic Unicorn, Ubuntu 14.04 Trusty Tahr, Linux Mint 17 Qiana, Elementary OS 0.3 Freya, Peppermint Five, Deepin 2014, LXLE 14.04, Linux Lite 2.0 and other Ubuntu 14.10 and Ubuntu 14.04 derivative systems.

For Ubuntu 14.10, Gaupol 0.26 is available via the default repositories, so all you have to do is:

$ sudo apt-get update
$ sudo apt-get install gaupol

Gaupol 0.26 is not available via any PPA for Ubuntu 14.04, Linux Mint 17, Elementary OS 0.3 and other Ubuntu 14.04 derivative systems, so we have to download the gaupol archive, extract it and execute the python installer:

$ wget http://download.gna.org/gaupol/0.26/gaupol-0.26.tar.xz
$ tar -xJvf gaupol-0.26.tar.xz
$ cd gaupol-0.26
$ sudo python3 setup.py clean install

Liked it? Take a second to support Geekster on Patreon!
Tagged with: , , , , , , , , , , , , , , , , , , , , , , , , ,
Posted in The Linux and Unix Articles!

Leave a Reply

Your email address will not be published. Required fields are marked *

*

Support LinuxG via Patreon
Support LinuxG.net on Patreon!
Subscribe

  

Subscribe to get the latest Linux news and how to guides directly on your e-mail!