How To Install Geany 1.23 On Ubuntu 13.10, 13.04, 12.10, 12.04, 10.04 And Linux Mint 15, 14, 13

Edit: Due to the fact that this article is old, the installation instructions may not work anymore. In order to successfully install the latest version of Geany, please access the geany tag and open the latest article (the one on top).

The latest installation instructions for Geany

Hello Linux Geeksters. As you may know, Geany is a small and lightweight IDE, independent from the desktop environments, so it only needs the GTK2 libraries, as dependencies, to run. The latest version available is Geany 1.23. For more information, see this page.

 how to install Geany 1.23 on Ubuntu 13.10 Saucy Salamander, Ubuntu 13.04 Raring Ringtail, Ubuntu 12.10 Quantal Quetzal, Ubuntu 12.04 Precise Pangolin, Ubuntu 10.04 Lucid Lynx, Linux Mint 15 Olivia, Linux Mint 14 Nadia and Linux Mint 13 Maya.

In this article I will show you how to install Geany 1.23 on Ubuntu 13.10 Saucy Salamander, Ubuntu 13.04 Raring Ringtail, Ubuntu 12.10 Quantal Quetzal, Ubuntu 12.04 Precise Pangolin, Ubuntu 10.04 Lucid Lynx, Linux Mint 15 Olivia, Linux Mint 14 Nadia and Linux Mint 13 Maya.

Geany 1.23 is available in the default repositories on Ubuntu 13.10 Saucy Salamander and Linux Mint 16 Petra, so just open a terminal and type:

$ sudo apt-get update
$ sudo apt-get install geany

To install Geany 1.23 on Ubuntu 13.04/12.10/12.04/10.04 and Linux Mint 15/14/13, you have to add the Geany development PPA, like this:

Add the PPA:

$ sudo add-apt-repository ppa:geany-dev/ppa

Update the local repositories:

$ sudo apt-get update

Install Geany:

$ sudo apt-get install geany

Liked it? Take a second to support Geekster on Patreon!
Tagged with: , , , , , , , , , , , , , , ,
Posted in The Linux and Unix Articles!
6 comments on “How To Install Geany 1.23 On Ubuntu 13.10, 13.04, 12.10, 12.04, 10.04 And Linux Mint 15, 14, 13
  1. Zazu says:

    Thanks for publish that! I was planning to install it from source

  2. sunway380 says:

    Facil,et simple à installer à partir du dépot, en tar.gz suit pas parvenu à l’installer.

    bon éditeur pour les language web.

  3. tilpa says:

    Just to share the good news, for those like me that are stuck in Ubuntu 10 for some weird reason…
    Chow Loong Jin had just released Geany v.1.24 .deb packages for Lucid 🙂
    Check it out at
    https://launchpad.net/~geany-dev/+archive/ubuntu/ppa

  4. Zacknov says:

    I can install geany in my linux. Thank You alot

  5. Wesley says:

    Muito OBrigado!

Leave a Reply to Lesa Cancel reply

Your email address will not be published. Required fields are marked *

*

Support LinuxG via Patreon
Support LinuxG.net on Patreon!
Subscribe

  

Subscribe to get the latest Linux news and how to guides directly on your e-mail!