How to Install Printer Driver Canon Pixma IP Series on Ubuntu

Hello Linux Geeksters

In this article I will show you how to install the most popular Canon Pixma IP Series Printer Drivers on Ubuntu 13.04 Raring Ringtail, Ubuntu 12.10 Quantal Quetzal and Ubuntu 12.04 Precise Pangolin

This article has installation instructions for:

Canon Pixma iP Series Ubuntu driver

  • Canon iP100 Ubuntu Driver -  cnijfilter-ip100series
  • Canon iP1800 Ubuntu Driver – cnijfilter-ip1800series
  • Canon iP1000 Ubuntu Driver – cnijfilter-pixmaip1000series
  • Canon iP1500 Ubuntu Driver – cnijfilter-pixmaip1500series
  • Canon iP1900 Ubuntu Driver – cnijfilter-ip1900series
  • Canon iP 2200 Ubuntu Driver – cnijfilter-ip2200series
  • Canon iP2500 Ubuntu Driver – cnijfilter-ip2500series
  • Canon iP2600 Ubuntu Driver – cnijfilter-ip2600series
  • Canon iP2700 Ubuntu Driver – cnijfilter-ip2700series
  • Canon iP3300 Ubuntu Driver – cnijfilter-ip3300series
  • Canon iP3500 Ubuntu Driver – cnijfilter-ip3500series
  • Canon iP3600 Ubuntu Driver – cnijfilter-ip3600series
  • Canon iP4200 Ubuntu Driver - cnijfilter-ip4200series
  • Canon iP4500 Ubuntu Driver – cnijfilter-ip4500series
  • Canon iP4700 Ubuntu Driver – cnijfilter-ip4700series
  • Canon iP4800 Ubuntu Driver – cnijfilter-ip4800series
  • Canon iP5200 Ubuntu Driver - cnijfilter-ip5200series
  • Canon iP6600 Ubuntu Driver – cnijfilter-ip6600series
  • Canon iP7500 Ubuntu Driver – cnijfilter-ip7500series

Add the repository and update the system:

$ sudo add-apt-repository ppa:michael-gruz/canon-trunk
$ sudo apt-get update

How to install the Printer Driver for Canon Pixma IP Series on Ubuntu:

Canon iP100 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip100series

Canon iP1800, iP1880, iP1890 Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip1800series

Canon iP1000 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-pixmaip1000series

Canon iP1500 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-pixmaip1500series

Canon iP1900 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip1900series

Canon iP2200 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip2200series

Canon iP2500 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip2500series

Canon iP2600 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip2600series

Canon iP2700 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip2700series

Canon iP3300 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip3300series

Canon iP3500 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip3500series

Canon iP3600 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip3600series

Canon iP4200 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip4200series

Canon iP4500 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip4500series

Canon iP4700 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip4700series

Canon iP4800 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip4800series

Canon iP5200 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip5200series

Canon iP6600 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip6600series

Canon iP7500 series Ubuntu Drivers:

$ sudo apt-get install cnijfilter-ip7500series

Share and Enjoy

  • Twitter
  • Facebook
  • Google Plus
  • Email
  • RSS
Tagged with: , , , , , , , , , , ,
Posted in The Linux and Unix Articles!
32 comments on “How to Install Printer Driver Canon Pixma IP Series on Ubuntu
  1. Uwe Mattheyer (alias Chichón or Beule) says:

    this site was very useful for me. Thanks

  2. rupy2009 says:

    thnks a million
    printing with my ip1900 was one of the few reasons y I ran back to windows …. whehhhhh
    instructions were a piece of cake :)

  3. doug says:

    Thanks, it was driving me crazy, I was searching in a lot of sites and I tried to install my ip1800 printer but the installation failled. Then I visited your site and reached to install it. Your instructions were util for me!!!

    Thanks a lot :)

  4. Axel... says:

    does not work .. supposedly already installed but I do not print

  5. Carson says:

    I am trying to get my ip3600 to work. I install everything and the install went fine. My printer will print a document, but when I try to print one later in that day (say an hour later) the document gets stuck in the queue and says processing.

    please help

    thanks

  6. Tom says:

    Thanks! Great tutorial man! IP1900 works well at least!

  7. Andrew says:

    Thank you for the solution for my printer! My Canon Pixma iP1800 works! Currently using Ubuntu 13.04.

    I had to switch from Debian 7.1.0 in order to get my printer working. I have used many methods to get my printer to work in Debian, but alas!

    Still, Ubuntu 13.04 does not provide driver for this printer out-of-box. So this article and the ppa mentioned in it are most useful.

  8. fleshback says:

    Thanks!!! Works fine!!

  9. Luca says:

    Hi, I am trying to install the driver cnijfilter-ip6600series on lubuntu 12.10 (which is essentially a repackaging of ubuntu 12.10), however when I run the apt-get install I only get
    E: Unable to locate package cnijfilter-ip6600series
    I get that probably it is looking for the right version for my distro, and does not find it. How can I finalise the install? I’m ready to bet that it should be working as under ubuntu.
    Thanks for help!

  10. Luca says:

    EDIT: I checked within synaptic, I found the driver and managed to install without problem. The printer is finally working as a charm! Thanks a lot.

  11. Cas says:

    Thanks, it was driving me crazy to install my ip2500 printer on
    Mint 15.
    Now it works fine!!

  12. tim says:

    excellent work! a real help and saved me from buying a new printer. i struggled for 3 days and tried a few other “solutions” but this how-to worked perfect, just a cut and paste.

  13. Dan says:

    Simply thanks, It works fine for my old ip2200 !

  14. David Oviedo says:

    Thanks a lot my ip2700 now are printing, thanks thanks

  15. Jack Young says:

    Many thanks! My ip1800 now works on Lubuntu 12.04.

  16. Wojtek says:

    This manual should be on Canon`s webpage. :) It`s great. Thank You!

  17. dequesto says:

    Yeah! My ip1800 is back! Thanks… :)

  18. Ken Sarkies says:

    Many thanks, you’re a gem.

    For those with Ubuntu 13.10, after running the commands given, call up synaptic, edit the repository entries that should be under “Other Software”, and change “saucy” to “raring”. Works beaut!

  19. Rod says:

    This also works with Kubuntu 13.10. Thank you!

  20. Jan says:

    Instant success. Great!

  21. Edy Susilo Hutomo says:

    Thank you, this article really helped me previously difficult to install Canon Ip1900 printer in Linux Mint 16 Petra

  22. Chepe says:

    Funciona muy bien en mi ip 1800 en Elementary, mil gracias, it’s possible in an version 86_64 thanks so much

  23. Fernando says:

    Thanks ! it finally worked for me.
    I initially saw another site where they suggested to add ppa without the “trunk” part, but this caused an error “404″ when I tried to update.
    After this I found this page and added the ppa with the “trunk” part, but still the “404″ error remained.
    So I finally had to go into the software sources, remove the first ppa and edit the second, changing the “precise” version to the “oneiric” version.(see http://www.omgubuntu.co.uk/how-to-add-a-ppa-to-software-sources-in-ubuntu)
    After this I installed the drivers and my canon ip1900 printer worked fine.

  24. Dirk says:

    Mint 16 (Petra) with Cinnamon 2.0.14, 64Bit
    Kernel 3.11.0-12-generic

    Canon iP2500: Working

    THANK YOU!

  25. Brigham says:

    I keep getting this message:
    “The following packages have unmet dependencies:
    cnijfilter-ip1800series : Depends: libtiff4 (> 3.9.5-3~) but it is not installable
    E: Unable to correct problems, you have held broken packages.”

    Help?

  26. allan says:

    worked for me canon ip1800

  27. Wolter says:

    I can’t believe someone finally published ip1800 drivers for amd64 linux :’)
    However, why do the drivers depend on X? I installed them also on an ubuntu-server and it started downloading X, some of GTK and even GStreamer.

1 Pings/Trackbacks for "How to Install Printer Driver Canon Pixma IP Series on Ubuntu"
  1. […] помощь пришла статья, в которой автор рассказал о PPA-репозитории c […]

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Subscribe

  

Subscribe to get the latest Linux news and how to guides directly on your e-mail!