How To Install Transmageddon 1.1 On Ubuntu 14.04, Linux Mint 17 And Their Derivative Systems

Hello Linux Geeksters. As you may know, Transmageddon is an open-source tool for converting audio and video files, based on GStreamer. The latest version available is Transmageddon 1.1, which got support for both DVD videos and Google’s VP9 compression.

And in order to use Transmageddon, you also need to install the GStreamer libraries, available via PPA.

how to install Transmageddon 1.1  on Ubuntu 14.04 Trusty Tahr, Linux Mint 17 Qiana, Pinguy OS 14.04 and Elementary OS 0.3 Isis.

In this article I will show you how to install Transmageddon 1.1  on Ubuntu 14.04 Trusty Tahr, Linux Mint 17 Qiana, Pinguy OS 14.04 and Elementary OS 0.3 Isis.

Add the GStreamer PPA, update the local repository index and install the gstreamer1.0 package, like this:

$ sudo add-apt-repository ppa:gstreamer-developers/ppa
$ sudo apt-get update
$ sudo apt-get install gstreamer1.0

Download and install Transmageddon:

$ sudo apt-get install gdebi
$ wget https://launchpad.net/ubuntu/+archive/primary/+files/transmageddon_1.1-2_all.deb
$ sudo gdebi transmageddon_1.1-2_all.deb

Enable DVD ripping:

$ sudo apt-get install lsdvd libdvdread4 gstreamer1.0-plugins-ugly
$ sudo /usr/share/doc/libdvdread4/install-css.sh

Optional, to remove gstreamer and transmageddon, do:

$ sudo apt-get remove gstreamer1.0 transmageddon

Share and Enjoy

  • Twitter
  • Facebook
  • Google Plus
  • Email
  • RSS
Tagged with: , , , , , , , , , , , , , ,
Posted in The Linux and Unix Articles!

Leave a Reply

Your email address will not be published. Required fields are marked *

*