PolyBrowser 2.0 (Gecko-based Internet Browser) Can Now Be Installed On Linux

PolyBrowser 2.0 is now available for Linux.

As you may know, PolyBrowser is yet another internet browser based on the Gecko engine, the same engine used by Firefox and Pale Moon. The browser focuses on working with multiple web pages at once, the most distinctive feature being the ability to zoom in and out of web pages, to monitor more tabs at once.

Also, it displays multiple web pages in panoramic view, permitting the users to easily bookmark files. The Zoom feature may be quite useful when used on large screens

The latest version available is PolyBrowser 2.0, which brings the following:

  • More popular addons, including LastPass, Firebug and Evernote
  • Now available for Linux
  • Faster UI and scrolling speed
  • Support for enhanced HTTP/2 standard
  • Misc fixes and improvements

PolyBrowser 2.0 (Gecko-based Internet Browser) Can Now Be Installed On Linux

Installation instructions:

PolyBrowser is not available via any repository, but the installation steps are quite easy anyway and should not create difficulties on any Linux distribution.

The latest versions of PolyBrowser are available as pre-compiled libraries via the Mozilla FTP, so we need to download the archive (i386 or i686 for 32 bit systems and amd64 or x86_64 for 64 bit systems), extract it and run the firefox file. Also, it is advised to remove previous versions of PolyBrowser, move PolyBrowser to /opt and create a symlink, for an easier usage.

The below instructions should work on all the popular Linux systems, including Ubuntu, Linux Mint, Pinguy OS, Elementary OS, Deepin, Peppermint, LXLE, Linux Lite, Debian, Robolinux, SparkyLinux, Fedora, CentOS, OpenSUSE, Mageia, OpenMandriva, Arch Linux, Manjaro, ROSA Desktop etc.

How to install PolyBrowser on 64 bit Linux systems:

$ wget http://polysuite.com/PolyBrowser/download/polybrowser-linux-2_0.tar.gz
$ tar -xzvf polybrowser-linux-2_0.tar.gz
$ sudo rm -rf /opt/polybrowser*
$ sudo mv polybrowser /opt/polybrowser
$ sudo ln -sf /opt/polybrowser/polybrowser /usr/bin/poly

To start PolyBrowser, just open a terminal, type poly and hit enter.

Tagged with: , , , , , , , , , , , , , , , , , ,
Posted in The Linux and Unix Articles!
2 comments on “PolyBrowser 2.0 (Gecko-based Internet Browser) Can Now Be Installed On Linux
  1. jazzoid says:

    Not working, some errors and typos in the instructions too (pollybrowser)
    Any updated instructions?

    Cheers

Leave a Reply to jazzoid Cancel reply

Your email address will not be published. Required fields are marked *

*

Subscribe

  

Subscribe to get the latest Linux news and how to guides directly on your e-mail!