How To Install Qtractor 0.5.12 On Ubuntu 13.10/12.04, Linux Mint 16/13, Elementary OS 0.2, Debian 7 And Fedora 19

Hello Linux Geeksters. As you may know, qTractor is a audio and midi sequencer, written in C++ and using Qt4 framework. The latest version of qTractor is qTractor 0.5.12 which brings many improvements to the previous version.For more information, see the official changelog.

how to install Qtractor 0.5.12 on Ubuntu 13.10 Saucy Salamander, Ubuntu 12.04 Precise Pangolin, Linux Mint 16 Petra, Linux Mint 13 Maya, Elementary OS 0.2 Luna, Debian 7 Wheezy and Fedora 19.

In this article I will show you how to install Qtractor 0.5.12 on Ubuntu 13.10 Saucy Salamander, Ubuntu 12.04 Precise Pangolin, Linux Mint 16 Petra, Linux Mint 13 Maya, Elementary OS 0.2 Luna, Debian 7 Wheezy and Fedora 19.

Because it is not available via any repository yet, we have to download the deb/rpm packages and install them with dpkg/rpm. Follow the instructions for your system exactly, in order to get a successful installation.

How to install Qtractor 0.5.12 on Ubuntu 13.10 Saucy Salamander and Linux Mint 16 Petra:

Instructions for 32 bit systems:

$ wget download.opensuse.org/repositories/home:/rncbc/xUbuntu_13.10/i386/qtractor_0.5.12svn3706-1_i386.deb
$ sudo dpkg -i qtractor_0.5.12svn3706-1_i386.deb
$ sudo apt-get install -f

Instructions for 64 bit systems:

$ wget download.opensuse.org/repositories/home:/rncbc/xUbuntu_13.10/amd64/qtractor_0.5.12svn3706-1_amd64.deb
$ sudo dpkg -i qtractor_0.5.12svn3706-1_amd64.deb
$ sudo apt-get install -f

How to install Qtractor 0.5.12 on Ubuntu 12.04 Precise Pangolin, Linux Mint 13 Maya and Elementary OS 0.2:

Instructions for 32 bit systems:

$ wget download.opensuse.org/repositories/home:/rncbc/xUbuntu_12.04/i386/qtractor_0.5.12svn3706-1_i386.deb
$ sudo dpkg -i qtractor_0.5.12svn3706-1_i386.deb
$ sudo apt-get install -f

Instructions for 64 bit systems

$ wget download.opensuse.org/repositories/home:/rncbc/xUbuntu_12.04/amd64/qtractor_0.5.12svn3706-1_amd64.deb
$ sudo dpkg -i qtractor_0.5.12svn3706-1_amd64.deb
$ sudo apt-get install -f

How to install Qtractor 0.5.12 on Debian 7 Wheezy:

Instructions for 32 bit systems:

$ wget download.opensuse.org/repositories/home:/rncbc/Debian_7.0/i386/qtractor_0.5.12svn3706-1_i386.deb
$ sudo dpkg -i qtractor_0.5.12svn3706-1_i386.deb
$ sudo apt-get install -f

Instructions for 64 bit systems:

$ wget download.opensuse.org/repositories/home:/rncbc/Debian_7.0/amd64/qtractor_0.5.12svn3706-1_amd64.deb
$ sudo dpkg -i qtractor_0.5.12svn3706-1_amd64.deb
$ sudo apt-get install -f

How to install Qtractor 0.5.12 on Fedora 19:

Instructions for 32 bit systems:

$ wget download.opensuse.org/repositories/home:/rncbc/Fedora_19/i686/qtractor-0.5.12svn3706-1.1.i686.rpm
$ sudo rpm -i qtractor-0.5.12svn3706-1.1.i686.rpm

Instructions for 64 bit systems:

$ wget download.opensuse.org/repositories/home:/rncbc/Fedora_19/x86_64/qtractor-0.5.12svn3706-1.1.x86_64.rpm
$ sudo rpm -i qtractor-0.5.12svn3706-1.1.x86_64.rpm

Tagged with: , , , , , , , , , , , , , , , , , ,
Posted in The Linux and Unix Articles!
2 comments on “How To Install Qtractor 0.5.12 On Ubuntu 13.10/12.04, Linux Mint 16/13, Elementary OS 0.2, Debian 7 And Fedora 19
  1. Jason Brewer says:

    Hi Geekster,

    I’m running Linux Mint 13 MATE 64 bit and I’m afraid your instructions no longer work (if they should work for MATE – which they should, right?)

    Anyhow, the command

    “wget download.opensuse.org/repositories/home:/rncbc/Debian_7.0/amd64/qtractor_0.5.12svn3706-1_amd64.deb”

    results in a 404 not found so I went and had a look in the current opensuse repositories and it turns out that the deb in there now can be found at:

    “download.opensuse.org/repositories/home:/rncbc/xUbuntu_12.04/amd64/qtractor_0.5.12.33svn3799-1_amd64.deb”

    A wget of this url works. All good so far. I then do the:

    sudo dpkg -i qtractor_0.5.12.33svn3799-1_amd64.deb

    command which terminates with:

    “Setting up qtractor (0.5.12.33svn3799-1) …”

    then the:

    sudo apt-get install -f

    command which helpfully informs me that 0 new packages have been installed. Very disheartening 🙁

    At no point in the process is any Qtractor source downloaded or compiled by the looks of things. This is an issue with the .deb on opensuse right?

    Any light you can shed would be far past brilliant. I’ve also tried downloading the 0.5.12 tarball from sourceforge but the included “configure” script doesn’t seem to accept that I actually do have jack installed.

    Sorry about the premature send of my previous comment by the way. I mis-middle clicked.

    Thank you and enjoi your Wednesday!

    Jason

Leave a Reply to Jason Brewer Cancel reply

Your email address will not be published. Required fields are marked *

*

Subscribe

  

Subscribe to get the latest Linux news and how to guides directly on your e-mail!